Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 04, 2026 - 05:30 UTC
Scheduled
We would like to inform you about the following maintenance of opsCTRL:
Start 2026-03-04 01:30 EST / 05:30 GMT End 2026-03-04 03:00 EST / 07:00 GMT
During the start of the maintenance, users may see a "maintenance" page for a short period of time. After the scheduled maintenance our new login page will be deployed, user credentials will stay the same.
Should you experience any issues after this maintenance, please contact our team on servicedesk@opsctrl.com or call +1 801-762-6838.
Posted Feb 25, 2026 - 14:43 UTC
This scheduled maintenance affected: opsCTRL Facility (opsCTRL Website, opsCTRL Facility Mobile App, Data Processing, Dashboard Module, Assets Module, Library Module, Maintenance Module, Alarms Module).