Potential opsCTRL Issues on Samsung Galaxy Devices

Incident Report for opsCTRL

Resolved

This issue issue now resolved, if any issues persist, please email servicedesk@opsctrl.com.
Posted Apr 25, 2025 - 14:03 UTC

Investigating

We are investigating reports that opsCTRL is not loading/performing well on Samsung Galaxy devices.

If you are experiencing this issue, please email servicedesk@opsctrl.com.

We will provide an update within 24 hours.
Posted Apr 24, 2025 - 19:56 UTC
This incident affected: opsCTRL Facility (opsCTRL Facility Mobile App).